Forum | Marketplace | Knowledge Base | | H1 site | H2 site | H3 site
Click Here To Visit Leroy Diesel
Click Here To Visit Leroy Diesel
Click Here To Visit Adventure Accessories
Click Here To Visit Adventure Accessories
Click here for a listing of all HUMMER Network sponsors

Hummer Knowledge Base

The Hummer Knowledge Base

Checking Instrument Grounds:

After replacement of the Injector Pump (rebuilt), the Temperature Gauge and Wait Lite stopped working and the Battery/Voltmeter reads low (about 11)!!!!

We've checked all the grounds....at least tried to.

Any thoughts or help?

OK, let's take a look. FIrst the feed to the voltmeter also feeds (tada) the tempature guage. It also feeds the oil pressure and fuel level guages too.

Now the wait light is a very different circuit. It is feed directly from the glowplug controller. So what's in common? The instrument panel ground point! Pull out the volt meter guage panel (four screws) and check the wires on the back of the voltmeter. One for hot, one ground, and a light (violet) wire. Connect your volt meter to a known good ground (test it!) and with the KOEO (key on, engine off) check voltage on the two meter terminals. One should be battery voltage, one should be ground. If the ground reads about two volts--then that is your bad ground.

Peter Hipson (founder, NEHOG)
1995 White NA Hummer Wagon


Back to main page

The Hummer Knowledge Base is a collection of informative posts from the Hummer Network forums and mailing lists, contributed material and links to outside web sites.
The Hummer Network is not responsible for the accuracy of the information contained herein or on outside web sites, nor for any situation arising from the use thereof.
2006-2011 by The Hummer Network. No material from the Hummer Knowledge Base may be reprinted or republished in any form without permission.